В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Anastasiya6565
Anastasiya6565
17.06.2022 10:31 •  Информатика

Составить программу вычисления суммы нечётных чисел от 1 до 99.

Ответ:
kaaanrakun
kaaanrakun
11.06.2020 23:10

//первый вариант

var

  i, summ:integer;

begin

  summ := 0;

  for i := 1 to 99 do

    if i mod 2 = 1 then

      summ := summ + i;

  writeln('Сумма нечетных чисел от 1 до 99 равна: ', summ);

end.

 

//второй вариант

var

  i, summ:integer;

begin

  summ := 0;

  i := 1;

  while i < 100 do

  begin

      summ := summ + i;

      i := i + 2;

  end;

  writeln('Сумма нечетных чисел от 1 до 99 равна: ', summ);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?