В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Bячеслав
Bячеслав
07.04.2020 05:54 •  Информатика

Напишите программу нахождения длин медиан m1,m2 и m3, треугольника по указанными формулами . длина сторон a,b,c задается с клавиатуры m1=1/2*sqrt(2a^2+2b^2-c^2); m2=1/2*sqrt(2a^2+2c^2-b^2); m3=1/4*sqrt(2b^2+2c^2-a^2); .

Ответ:
foxylol1
foxylol1
11.06.2020 21:07

var
    a, b, c: real;

function mediana(a, b, c: real): real;
begin
    mediana := 1 / 2 * sqrt(2 * a * a + 2 * b * b - c * c);
end;

begin
    writeln('Введите длины сторон треугольника a b c');
    read(a, b, c);
    writeln('m1 = ', mediana(a, b, c));
    writeln('m2 = ', mediana(a, c, b));
    writeln('m3 = ', mediana(b, c, a));
end.

0,0(0 оценок)
Ответ:
esina3010
esina3010
11.06.2020 21:07

 Pascal ABC(проверьте правильность написанных вами формул...)

 

uses crt;
var a,b,c,m1,m2,m3 : integer;
begin
writeln('Введите длины сторон треугольника a b c');
read(a,b,c);
m1:=1/2*sqrt(2*a^2+2*b^2-c^2);
m2:=1/2*sqrt(2(a^2+2*c^2-b^2);
m3:=1/4*sqrt(2*b^2+2*c^2-a^2);
writeln('m1= ',m1,'m2= ',m2,'m3= ',m3);
end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?