В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Медина00
Медина00
22.01.2023 15:47 •  Информатика

Написать программу: дано 5 произвольных натуральных чисел. найти среднее арифметическое отрицательных кратных пяти.

Ответ:
littleeeprincess
littleeeprincess
03.10.2020 05:44
Program z1;
var
mas: array[1..10] of integer;
i,s,sr,k: integer;
begin
s:=0;
k:=0;
writeln('Введите 5 чисел');
for i:=1 to 5 do
begin
readln(mas[i]);
if (mas[i]<0) and (mas[i] mod 5=0) then
begin
s:=s+mas[i];
k:=k+1;
end;
end;
sr:=s div k;
writeln('Среднее арифметическое чисел, кратных 5, равно ',sr);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?