В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
son9a
son9a
19.12.2020 07:23 •  Информатика

Напишите программу, которая преобразует сумму денег (целое число), предоставленную пользователем, в минимально возможное количество монет и банкнот достоинством 1, 2, 5, 10, 20, 50 злотых. Кроме того, программа отображает количество всех банкнот и монет.

Ответ:
zill81
zill81
08.11.2020 13:40

Объяснение:

#include <iostream>

int main()

{

   size_t sum, i = 0;

   const size_t nominals[] = { 5000, 2000, 1000, 500, 200, 100, 50, 10, 5, 2, 1 };

       

   std:cin >> sum;

   while(sum)

   {

       if (sum / nominals[i] > 0)

       {

           std::cout << nominals[i] << "  ";

           sum -= nominals[i];

       }

       else

           ++i;

   }

   return 0;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?