В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
vita9251
vita9251
04.04.2020 04:02 •  Информатика

Напишите программу на Паскале, используя цикл for.

Найти сумму из n введенных чисел.​

Ответ:
sabinaqUliyeva
sabinaqUliyeva
06.12.2020 01:25

program amountn;

var

 amount, n, number, i: integer;

begin

 amount := 0;

 write('Введите количество чисел: ');

 read(n);

 for i := 1 to n do

 begin

   read(number);

   amount := amount + number;

 end;

 writeln('Сумма n чисел: ', amount);

end.

Объяснение:

program amountn;  // Название программы

var

 amount, n, number, i: integer;  // Целочисленные переменные:

amount - сумма чисел;n - количество чисел;number - сами числа;i - счетчик для цикла for.

begin  // Начало программы

 amount := 0; // Переменная, хранящая сумму, = 0

 write('Введите количество чисел: ');  // Вывод сообщения в консоль

 read(n);  // Считываем количество чисел с клавиатуры

 for i := 1 to n do  // Идём с единицы до n (цикл для ввода n чисел)

 begin  // Начало цикла

   read(number);  // Считываем число с клавиатуры

   amount := amount + number;  // К переменной, хранящей сумму, прибавляем число

 end;  // Конец цикла

 writeln('Сумма n чисел: ', amount);

end. // Конец программы

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?