В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Rianariana2002
Rianariana2002
08.02.2020 23:45 •  Информатика

Требовалось написать программу, которая получает на входе натуральное число n и выводит число, которое получается из n после удаления всех пятерок, порядок остальных цифр при этом не меняется. программист торопился и написал программу неверно, найдите неверную строку и исправьте ее. var n, r, t: longint; d: integer; begin readln (n); r: =0; t: =1; while n> 0 do begin d: =n mod 10; if d=5 then begin r: =r+d*t; t: =t+1 end; n: =n div 10; end; writeln (t); end.

Ответ:
Mишутка9887
Mишутка9887
01.10.2020 18:55
Var n, r, t:longint; 
d:integer;
begin  
readln (n); 
 r:=0;  t:=1;  
while n>0 do begin  
d:=n mod 10;  if d=5 then begin    1 ошибка: надо вместо d=5 написать d<>5
 r:=r+d*t;  
t:=t+1                                         2 ошибка: надо вместо t+1 написать t*10
end; 
n:=n div 10;
 end;
writeln (t);                                   3 ошибка: надо вместо t написать r
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?