В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык

Написать программу которвя вычисляет сумму n первых чисел кратных 2

Ответ:
оооооаомт
оооооаомт
12.02.2021 15:37

На будущее, уточняйте на каком языке программирования нужно написать. Так как не указано язык программирования, то я просто напишу алгоритм, а Вы уже сами постараетесь перевести на нужный язык.

int sum; - создаем переменную sum;

int n; - создаем переменную n;

int index = 0; - создаем переменную index, при которой будем считать сколько раз введено число, которое кратное 2;

while(index != 2){ - создаем цикл, который будет спрашивать ввод числа n до тех пор, пока мы не напишем два числа которые будут кратные 2;

cin >> n; - вводим наше n;

if( (n % 2) == 0){ - пишем условия, в котором проверяем, если остаток от деления на 2, равен 0, то мы делаем некоторые вещи, а именно:

sum = sum + n; - в нашу суму добавляем число n;

index = index + 1; - "записываем" в index понятие, что мы нашли уже одно число.

}

cout << sum; - выводим нашу итоговую сумму.

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?