В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
DariaShistad18
DariaShistad18
07.04.2023 06:09 •  Информатика

Условие

Напишите программу, которая считает три числа и большее из них уменьшит на 5.

Формат входных данных

Вводится три различных целых числа a, b, c (−230≤a,b,c≤230−1)

Формат выходных данных

Требуется вывести новые значения этих чисел

входные данные

10 11 12

42 13 6

выходные данные

10 11 7

37 13 6

Ответ:

#include <iostream>

using namespace std;

signed main() {

   int a,b,c;

   cin >> a >> b >> c;

   if(a > b && a > c)

       a -= 5;

   else if(b > a && b > c)

       b -= 5;

   else if(c > a && c > b)

       c -= 5;

   cout << a << " " << b << " " << c;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?