В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
оксана731
оксана731
09.08.2022 13:28 •  Информатика

Напишите программу которая определяет является ли число простым.

Ответ:
mpaxomow
mpaxomow
11.06.2020 05:51

Program PrimeNumber;

Uses Crt;

var i,f,n:integer;
begin

     clrscr;
      write('Введите число:');
      readln(n);

      f:=0;  
      for i:=2 to trunc(sqrt(n)) do
              if (n mod i)=0 then f:=1;
      if (f=0) then writeln('Число является простым')

                     else writeln('Число не является простым');
      readkey;
end.

 

 

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?