В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
HelenToys
HelenToys
16.01.2021 06:35 •  Информатика

Заводные жуки в квадрате Написать программу на python, отвечающую этим требованиям
Есть такая математическая задача, в которой жуки двигаются из четырех углов квадрата всегда в направлении соседнего жука с одинаковой скоростью и в одном направлении. Нужно найти расстояние, которое пройдет каждый жук до встречи в центре квадрата.
Задача решается легко, если перейти в систему отсчета одного из жуков и понять, какое расстояние ему нужно пройти. Хотя траектория движения жуков довольно сложная — это логарифмическая спираль.
Немного изменим условие.
PIC
У нас будут двигаться механические жуки. Такой жук движется одну секунду по своей стороне квадрата, затем мгновенно определяет положение ближайшего спереди и справа жука, поворачивает к нему и снова движется одну секунду по стороне уже меньшего квадрата. Так продолжается, пока сторона квадрата, по которой движется жук, не станет меньше или равна расстоянию, которое он должен пройти за секунду.
Теперь траектория жука — это ломаная линия.
Найдите количество поворотов, которые пришлось сделать каждому жуку.
Формат ввода
На отдельных строках вводятся 2 вещественных числа: сторона квадрата и скорость жука в секунду.
Формат вывода
Целое число — количество поворотов жука.
Пример
Ввод Вывод
2 3
1

Примечания
Поскольку в этой задаче нужно сравнивать вещественные числа, давайте это делать с точностью до сотых. abs(x − y) <= 0.01

Ответ:
dstepin17
dstepin17
25.11.2020 20:16

from math import sqrt

dist = float(input())

speed = float(input())

i = 0

while dist - speed > 0.01:

   dist = sqrt((dist - speed) ** 2 + speed ** 2)

   i += 1

print(i)

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?