В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
лиза2713
лиза2713
15.04.2022 03:45 •  Информатика

На основании исходных данных необходимо написать программу и получить ответ. Рассматривается множество целых нечетных чисел, принадлежащих числовому отрезку
[-1000; 2000], которые делятся на 17 или 23 и не оканчиваются на 3 или 5.
Найдите количество таких чисел и максимальное из них. В ответе запишите два целых
числа: сначала количество, затем максимальное число,​

Ответ:
321Shark
321Shark
20.11.2020 23:02

Объяснение:

Программа на Питоне:

a=[]

m=-1001

n=0

p=int(input('Сколько будет чисел: '))

print('Вводите числа:')

for i in range(p):

  a.append(int(input()))

for i in a:

  if ((i % 17)==0 or (i % 23)==0 ):

      s=str(i)

      if not(s[-1]=='3' or s[-1]=='5'):

          if i>m:

              m=i

          n+=1

print('Количество: ',n)

if n>0:

  print('Максимальное:',m)

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?