В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Лиза505090
Лиза505090
02.04.2023 16:04 •  Информатика

Написать программу в паскале. найти наибольший общий делитель 2 натуральных чисел!

Ответ:
ПудинговыйГраф
ПудинговыйГраф
10.06.2020 22:17

program prim; uses crt; var x,y:integer; begin writeln ('введите x,y'); readln (x,y); while x<>y do begin if x>y then x:=x-y else y:=y-x end; write ('НОД=',x); end.

0,0(0 оценок)
Ответ:
asdfgh21
asdfgh21
10.06.2020 22:17

var a,c,b:integer;
begin
readln(a,b);
while b>0 do begin
a:=a mod b;
c:=a;a:=b;b:=c;
end;
writeln(a);
end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?