В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
BasketballGrand
BasketballGrand
29.06.2020 08:38 •  Информатика

Составить программу на языке программирования паскаль, которая бы содержала бы как минимум три ветвления (if then else и один цикл (for i : = 1 to do

Ответ:
andreytolstik
andreytolstik
30.09.2020 19:09

program yourname;
uses crt;
var com:string; i:integer;
begin
writeln('Задайте значените программы.');
writeln('Для того чтобы программа посчитала от 1 до 5 пропишите команду  "go1".');
writeln('Для того чтобы программа посчитала от 5 до 1 пропишите команду  "go2".');
writeln('Для того чтобы сказать программе - пропишите команду "go3".');
readln(com);
If (com = 'go1') then begin
writeln(Программа считает от 1 до 5');
for i:=1 to 5 do writeln(i) end
else if (com = 'go2') then begin
writeln('Программа считает от 5 до 1');
for i:=5 downto 1 do writeln(i) end
else if (com = 'go3') then begin
writeln('Программа: Всегда рада вам
else begin writeln('Данной команды не существует либо вы ввели команду вместе с ковычками.');
Перезапустите программу.') end

 

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?