В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Atoom51
Atoom51
26.05.2023 09:11 •  Информатика

Программа получает на вход натуральное число, большее 9. Вывести число, которое получится в результате перестановки его последней и предпоследней цифр. ЯЗЫК C++

Ответ:
dilyabasmanova
dilyabasmanova
02.10.2020 06:01
Код#include <iostream>#include <string>#include <functional>std::string switch_first_and_last(std::string N) {    auto L = N.size() - 1;    return N[L] + N.substr(1, L - 1) + N[0];}bool take_correct_number(int &number, const std::function<bool(int)>& Q) {    do {        std::cin >> number;        if (!Q(number)) {            std::cout << "Try again." << std::endl;            continue;        }        break;    } while (true);    return true;}int main() {    int number;    take_correct_number(number, [](int x){return x > 9;});    std::cout << switch_first_and_last(std::to_string(number)) << std::endl;}
Программа получает на вход натуральное число, большее 9. Вывести число, которое получится в результа
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?