В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
heni2001
heni2001
27.04.2021 09:24 •  Информатика

Система Паскаль. Напишите программу, которая в последовательности натуральных чисел определяет сумму всех чисел, кратных 3 и оканчивающихся на 4. Программа получает на вход натуральные числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 — признак окончания ввода, не входит в последовательность). Количество чисел не превышает 1000. Введённые числа не превышают 30000. Программа должна вывести одно число: сумму всех натуральных чисел, кратных 3 и оканчивающихся на 4.

Ответ:
sassshaaa
sassshaaa
25.09.2020 06:01

pascal

Объяснение:

program summa;

var i, s: integer;

begin

 WriteLn('Введите числа (или 0, чтобы закончить: ');

 repeat

   Write('i = ');

   ReadLn(i);

   if (i mod 3 = 0) and (i mod 10 = 4) then s := s + i;

 until i = 0;

 WriteLn('Сумма введенных натуральных чисел, кратных 3 и оканчивающихся на 4, равна ', s);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?