Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
danilbalabanov
03.02.2023 18:48 •
Информатика
Водномерном массиве а подсчитать число положительных элементов, имеющих четный индекс. отрицательные элементы массива заменить нулями (в паскале)
Ответ:
danil200804
19.06.2020 04:57
Var a: array [1..100] of real;
n, i, kol: integer;
begin
readln(n);
for i := 1 to n do
read(a[i]);
kol := 0;
for i := 1 to n do begin
if (a[i] > 0)and(i mod 2 = 0)
then kol := kol + 1;
if a[i] < 0
then a[i] :=0;
end;
writeln(kol);
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
suri4
21.01.2021 22:17
(паскль)составьте программу выполняющую расчет площади треугольника...
Ксения80200
15.09.2022 08:45
10 класс.чтотакое земельщина?...
Derety11
13.12.2021 12:11
Морфологический разбор причастия рассматриваемый (проект)...
baha50
15.09.2021 19:16
Сплильне коренів слово до слово рід...
milanka28082006
21.02.2020 02:27
10 речень про злочин на ійську мову...
arinochkakor1
21.02.2020 02:27
Двухлитровая банка наполняется водой за 8 с. за какое время наполнится бочка ёмкостью 60 л? ...
eiapple02
07.07.2020 04:28
Казтуган жырлпрымен салыстырып...
ВасилисаВозгесенская
28.01.2022 16:05
Трапеция abcd равнобедренная , отрезок cm параллельно ab, известно что ad равно 20 см, bc 12 см, ab-7 см. установить вид треугольника mcd и найти его перимет...
роза413
03.03.2022 21:56
Продовжте текст своїми роздумами про те ми має держава дбати про популяризацію творчості талановитих українських митців чи все ж таки справжній шедевр рано чи пізно знайде...
xtreil181пингвинчик
13.11.2022 14:50
Укажите, при каком значении х верно равенство 15/х = 3/20...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
n, i, kol: integer;
begin
readln(n);
for i := 1 to n do
read(a[i]);
kol := 0;
for i := 1 to n do begin
if (a[i] > 0)and(i mod 2 = 0)
then kol := kol + 1;
if a[i] < 0
then a[i] :=0;
end;
writeln(kol);
end.