В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
45r77yf
45r77yf
06.04.2023 13:57 •  Информатика

Написать программу в Pascal: Найти сумму квадратов всех целых чисел от а до b (значение а и b вводятся с клавиатуры, b больше а).​

Ответ:
solomijahladij6
solomijahladij6
20.09.2020 01:01

program skab;

uses

crt;

var

i, a, b, s: integer;

begin

s := 0;

writeln('Введите a, затем b (a<b) :');

readln(a, b);

if a < b then

begin

for i := a to b do

s := s + (i * i);

writeln('Сумма квадратов целых чисел от а до b: ', s);

end

else

writeln('Ошибка! Проверьте правильность введённых данных! Закрытие программы...');

readln;

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?