В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
мозк2
мозк2
21.01.2022 15:22 •  Информатика

Вpascal abc написать программу, используя цикл while, которая находит одинаковые цифры двух трёхзначных чисел, при этом на экран с клавиатуры должны выводиться только трёхзначных числа, только чётные и только различные

Ответ:
voprooos
voprooos
04.10.2019 06:10

program fantscrin;

    var x_1,x_2,h,j,i: integer; f: boolean; a: array [1..3] of string; k,l: string;

    function chek_number(a: integer): boolean;

    var k: integer;

    begin

      if (a mod 2 < > 0) then  

                        begin  

                          chek_number: =false;

                          exit;

                        end;                  

      while a > 0 do

      begin

        a: =a div 10;

        k: =k+1;

      end;

      if (k = 3) then chek_number: =true

                else chek_number: =false;  

    end;

begin

    f: =false;

    while f = false do

    begin

      write('введите 1-ое число: '); readln(x_1);

      f: =chek_number(x_1);

    end;

    f: =false;

    while f = false do

    begin

      write('введите 2-ое число: '); readln(x_2);

      f: =chek_number(x_2);

      if (f) then if (x_1 < > x_2) then f: =true

                                  else f: =false;

    end;

   

    str(x_2,l);

    str(x_1,k);

    i: =1;

    h: =1;

    while i< =3 do

    begin

      j: =1;

      while j< =3 do

      begin

        if (k[i] = l[j]) then  

                        begin    

                            a[h]: =k[i];

                            h: =h+1;

                        end;

        j: =j+1;

      end;

      i: =i+1;

    end;

    writeln('');  

    i: =1;

    while i < =3 do

    begin

      write (a[i], '   ');

      i: =i+1;

    end;

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?