В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
kartoshka212
kartoshka212
05.04.2023 07:05 •  Информатика

(Pyton)Составьте программу вычисления суммы нечетных чисел в диапазоне от 1 до 10.

Ответ:
naoimiiwsvb2
naoimiiwsvb2
15.10.2020 16:03

def reduce(function, iterable, initializer=None):

   it = iter(iterable)

   if initializer is None:

       value = next(it)

   else:

       value = initializer

   for element in it:

       value = function(value, element)

   return value

a, b = 1, 10

print(reduce(lambda s, n: s + n, range(a, b+1, 2), 0))

0,0(0 оценок)
Ответ:
nkarlikova
nkarlikova
15.10.2020 16:03

sum = 0

i = 1

while i <= 10:

   sum += i

   i += 2

print(sum)

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?