В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык

решите нужно очень (составить программу определения общего сопротивления электрической цепи при последовательном и параллельном соединении трех резисторов)

Ответ:
Лиза18511
Лиза18511
15.10.2020 13:13

Объяснение:

const    

n = 10;    

r1 = 2;  

  r2 = 4;    

r3 = 3;

var  

  temp1, temp2: Real; begin  

  temp1 := r1 * ((n div 2) * (n + 1) + Ord(Odd(n)) * ((n div 2) + 1));    

temp2 := 2 * r2 * r3 / (r2 + r3);  

  WriteLn('R=',  (r1 + temp1 * temp2 / (temp1 + temp2) + r2):0:4);

end.

0,0(0 оценок)
Ответ:
соня3161
соня3161
15.10.2020 13:13
                                     PascalABC.NET                                       beginvar n := ReadInteger('Введите количество резисторов:');var Rs := ReadArrInteger('Введите их сопротивления:',n);Writeln(NewLine, 'Общее сопротивление цепи равно:');Println(' при последовательном соединении -', Rs.Sum,'Ом');Println(' при параллельном соединении -', 1/Rs.Sum(r->1/r),'Ом');end.

или кратко:

beginvar Rs := ReadArrInteger(3);Println('послед:', Rs.Sum);Println('парал:', 1/Rs.Sum(r->1/r));end.

Пример работы:


решите нужно очень (составить программу определения общего сопротивления электрической цепи при посл
решите нужно очень (составить программу определения общего сопротивления электрической цепи при посл
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?