В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
чебурек48
чебурек48
27.05.2020 12:10 •  Информатика

Напишите программу, которая получает с клавиатуры два натуральных числа и находит их НОД с алгоритма Евклида. Программа должна подсчитать количество шагов цикла. С

Ответ:
Небатан1542
Небатан1542
15.10.2020 11:11

#include <iostream>

using namespace std;

int NOD(int a, int b) {

   

   int iter = 0;

   if (a < b) {

       swap(a, b);

   }

   while (a % b != 0) {

       a = a % b;

       swap(a, b);

       iter++;

   }

   cout<<"NOD: "<< b << " Iteration: "<< iter;

}

int main()

{

   int a,b;

   cin>>a>>b;

   NOD(a,b);

   return 0;

}


Напишите программу, которая получает с клавиатуры два натуральных числа и находит их НОД с алгоритма
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?