В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
mike961
mike961
28.01.2022 23:28 •  Информатика

Напишите программу на c++, ! программе на вход подаётся 10 вещественных чисел. выведите их в обратном порядке. пример ввода: 5.3 1.47 9.23 3.08 2.25 5.62 6.93 3.67 8.44 6.49 пример вывода: 6.49 8.44 3.67 6.93 5.62 2.25 3.08 9.23 1.47 5.3

Ответ:
Sadist702
Sadist702
09.06.2020 12:05

#include <iostream>

int main()

{

float Number[10];

for (int i = 0; i < 10; i++) {

 std::cin >> Number[i];

}

for (int i = 0; i < 10; i++) {

 for (int j = 0; j < 10; j++) {

  if (Number[i] < Number[j]) {

   float temp = Number[j];

   Number[j] = Number[i];

   Number[i] = temp;

  }

 }

}

for (int i = 0; i < 10; i++) {

 std::cout << Number[i] << "\t" ;

}

return 0;

}

Объяснение:

Работает правильно, но возможно был допущен недочёт в алгоритме, для сортировки использовал пузырьковую сортировку.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?