В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Ксенечка4
Ксенечка4
01.10.2022 22:08 •  Информатика

с информатикой. Нужно написать программу в паскаль.

Ответ:
Прммрррр
Прммрррр
11.10.2020 13:49

1. Я игриком обозначил знак функции (f)

program z1;

var y: integer;

x: real;

begin

read(x);

if (-2.4 <= x) and (x <= 5.7) then y:= sqr(x)

else y:= 4;

end.

2. program z1;

var a, b, c: integer;

begin

if (a = b) and (b = c) and (a = c) then write('Треугольник является равносторонним')

else write('Треугольник не является равносторонним');

end.

3. program z1;

var a, b, c: integer;

begin

if (a = b) or (a = c) or (b = c) then write('Треугольник является равнобедренным')

else write('Треугольник не является равнобедренным')

end.

*Важно:

В 2 и 3 номерах я указывал тип переменным integer, поскольку не сказано, что длины сторон являются целыми. Если длины сторон с дробной частью (например: 2.3 см), то типы данных меняем на real.

Удачи на уроке

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?