В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Sofiamarfiya
Sofiamarfiya
02.09.2022 10:19 •  Информатика

очень Составить программу на языке Паскаль и записать в тетрадь по алгоритму

Алгоритм решения линейного уравнения ах=в, где а и в произвольные вещественные числа

алг линейноеуравнение

арг а,в

рез х,у

нач

если а≠0

то у:= «есть решение» х:=в/а

иначе если в=0 то у:= «х-любое число» иначе у:= «решений нет»

всё

всё

кон

Ответ:
Anna19013
Anna19013
30.08.2020 08:19

var

a, b, x,y:Real;

begin

ReadLn(a, b);

if (a<0) or (a>0) then

begin

y:= b/a;

WriteLn(y);

end

else if (b<0) or (b>0) then

WriteLn('Решений нет')

else

WriteLn('x-любое число');

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?