В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Zhenechka12332145
Zhenechka12332145
15.02.2021 05:39 •  Информатика

Очень Напишите программу подсчета количества положительных, количества нулевых и количества отрицательных элементов массива. Проверьте работу программы на заданном массиве А = {7, 25, 4.5, 0, 17, 61, -10, 0, 1, -4, 22}.

Кол-во полож. элементов:

Кол-во нулевых элементов:

Кол-во отриц. элементов:

Ответ:
Kachalova54
Kachalova54
15.10.2020 00:41

var

 a:array [1..11] of real;

 i,s1,s2:integer;

begin

 s1:=0; s2:=0;

 for i:=1 to 11 do

   begin

     readln(a[i]);

     if a[i]>0 then

       inc(s1)

         else

           if a[i]<0 then

             inc(s2);

   end;

 writeln('<0: ', s2);

 writeln('>0: ', s1);

 writeln('=0: ', i-s1-s2);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?