В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Bordeaux
Bordeaux
08.11.2021 02:26 •  Информатика

Составить программу которая вычисляет разницу между средним арифметическим матрицы и средне арифметическим значением диагональных элементов

Ответ:
mariyer
mariyer
09.06.2020 04:36

ответ:#include "pch.h"

#include <iostream>

using namespace std;

//Среднее арифметическое элементов матрицы

float AvarageMatrix(int** array, int n, int m)

{

float k = n*m, sum = 0.0;

for (int i = 0; i < n; i++)

{

 for (int j = 0; j < m; j++)

 {

  sum += array[i][j];

 }

}

return sum / k;

}

//Среднее арифметическое диагональных элементов

float AvarageDiagonal(int** array, int n, int m)

{

float k = n * m, sum = 0.0;

for (int i = 0; i < n; i++)

{

 for (int j = 0; j < m; j++)

 {

  if ((i == j) or (i + j == n-1))

  {

   sum += array[i][j];

  }

 }

}

return sum / k;

}

int main()

{

setlocale(0, "");

int n, m, k;

cout << "Введите размеры матрицы\n";

cout << "Количество строк:";

cin >> n;

cout << "Количество столбцов:";

cin >> m;

int** array = new int* [n];

for (int i = 0; i < n; i++)

{

 array[i] = new int[m];

}

cout << "Введите элементы массива:\n";

for (int i = 0; i < n; i++)

{

 for (int j = 0; j < m; j++)

 {

  cin >> k;

  array[i][j] = k;

 }

}

cout << "Искомая разница:" << AvarageMatrix(array, n, m) - AvarageDiagonal(array, n, m);

for (int i = 0; i < n; i++)

{

 delete[] array[i];

}

delete[]array;

system("pause");

return 0;

}

Объяснение:

Массивы динамические, удаляются в программе. Алгоритмы вычисления среднего арифметического диагональных элементов и элементов матрицы реализованы в функциях AverageDiagonal и AverageMatrix соответственно

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?