В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
melnikowapolia
melnikowapolia
28.08.2021 07:31 •  Информатика

Информатика Составьте программу нахождения произведения всех натуральных чисел из диапазона от А до В, включая А и В, кратных 2 и 3 одновременно(А и В вводятся с клавиатуры).

Ответ:
Dmutrenkovladuslav12
Dmutrenkovladuslav12
14.10.2020 21:00

program z1;

var i,a,b,p:integer;

begin

write('a = ');

readln (a);

write('b = ');

readln (b);

p:=1;

for i:=a to b do

if (i mod 2 = 0) and (i mod 3 =0) then p:=p*i;

if p <> 1 then writeln ('Произведение чисел, кратных 2 и 3 одновременно, равно ',p)

end.

Объяснение:

Если таких чисел нет, то программа ничего не выводит.

Если промежуток очень большой, то лучше изменить тип p (например, на real), чтобы не было переполнения.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?