В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
nizomabdurahmon
nizomabdurahmon
09.10.2020 00:44 •  Информатика

Нужна прога в синтаксисе pascal abc составить программу матрицу 10х10, заполненную случайным образом посчитать сумму элементов главной диагонали определить количество элементов < сумма/15 var a: array[1..10,1..10] of integer; i,j,summ,kol: integer; begin randomize и тд за ответ 30

Ответ:
skidan2002
skidan2002
20.08.2020 23:56
PascalABC.NET 3.3 под девизом
"Памяти наших дедов посвящается..."

const
  n=10;
var
  a:array[1..n,1..n] of integer;
  i,j,SumDiag,k:integer;
  p:real;

begin
  Writeln('*** Исходная матрица ***');
  Randomize;
  SumDiag:=0;
  for i:=1 to n do begin
    for j:=1 to n do begin
      a[i,j]:=Random(199)-99;
      if i=j then SumDiag:=SumDiag+a[i,j];
      Write(a[i,j]:4)
      end;
    Writeln
    end;
  for i:=1 to 4*n do Write('-');
  Writeln;
  Writeln('Сумма элементов на главной диагонали ',SumDiag);
  p:=SumDiag/15;
  k:=0;
  for i:=1 to n do
    for j:=1 to n do
      if a[i,j]<p then k:=k+1;
  Writeln('Искомое количество элементов ',k)
end.

Пример
*** Исходная матрица ***
  95  37  30  21  83 -99  48 -40  49 -19
 -66 -82  88 -24  70  14 -88  11  60  14
 -72 -80  90  25  68  23  91  66 -54  52
  33  16  25 -72  85  58 -39  44   8 -29
   8  78 -79  51  50 -61 -13 -87  87  66
  63 -45  94 -48  59  76  46 -94  53 -40
 -90  81 -85  96  47  18  -8  61 -10 -87
 -47 -33 -97 -10 -93 -51  98 -60  74  30
 -63  78  79 -21  89 -21  21 -26 -31 -91
 -88 -45  91 -51 -39  26  64 -75 -96 -67

Сумма элементов на главной диагонали -9
Искомое количество элементов 46
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?