В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
adidas128
adidas128
08.07.2020 15:06 •  Информатика

Напишите программу, которая считывает натуральное число n и выводит на экран случайное натуральное число, меньшее n и оканчивающееся на 1. Гарантируется, что будет ввeдено натуральное число 1

Ответ:
БеднаяЕва
БеднаяЕва
14.10.2020 12:06

Программа:

program MrSolution;

var n: integer;

function MrSolutionRandom(topBorder: integer):integer;

var rand: integer;

begin

 randomize;

 rand:= random(0, topBorder-1);

 MrSolutionRandom:= rand-rand mod 10+1;

end;

begin

  write('Введите натуральное число, кроме 1 >> ');

  repeat

    readln(n);

  until n<>1;

  writeln(MrSolutionRandom(n));

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?