Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
didlok
31.01.2020 05:31 •
Информатика
Сформировать массив содержащий 15 элементов с датчика случайных чисел . получите новый массив каждый элемент которого равен удвоенному соответствующиму элементу исходного массива
Ответ:
Tramontino
07.10.2020 10:50
// PascalABC.NET 3.3, сборка 1590 от 03.12.2017
// Внимание! Если программа не работает, обновите версию!
begin
var a:=ArrRandom(15,-50,50); a.Println;
var b:=a.Select(t->2*t).ToArray; b.Println
end.
Пример
28 -22 -43 -36 -20 -21 36 -26 48 25 -31 -29 8 -35 17
56 -44 -86 -72 -40 -42 72 -52 96 50 -62 -58 16 -70 34
0,0
(0 оценок)
Ответ:
Алкадиеныч
07.10.2020 10:50
Const Sz = 100; // Размер массива
var
a,b: array [1..Sz] of integer;
N: integer; // Количество элементов в массиве
i: integer;
begin
N := 20;
for i:=1 to N do begin
a[i] := Random(100);
b[i]:=a[i]*2;
writeln('Элементы массива: ');
for i:=1 to N do
writeln(a[i],' ',b[i]);
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
ззвееррекк
20.02.2023 21:55
Формула =$A2+B$3 была скопирована из ячейки B6 в ячейку C8. Какая формула получилась в C8?...
ник200781
09.07.2022 22:12
Чем отличается информационная грамотность от цифровой, что из них важнее?...
irenda828001
07.08.2020 05:20
Как связаны мощность алфавита и разрядность двоичного кода, достаточно ли для кодирование всех символов этого алфавита?...
antonishyna1997
06.12.2022 02:20
Есть два кувшина ёмкостью 3 и 8 литров. как с только этих кувшинов набрать из реки 7 литров воды? условия выполнения: 1. наливать кувшины из реки можно только дополна....
18Tanya
06.12.2022 02:20
1. составить программу для вычисления x и y по формулам...
Nastya060104sataeva
20.05.2022 07:22
Вопрос 5 Укажите предложение с ошибкой. Отважная разведчица Нина добыла нужные сведения. Софья — хороший программист. Врач Смирнова выписал рецепт в чтение 5 минут умоляю!...
katushashamrova
09.04.2020 09:35
8-9 речень твір на роздум рух у моєму житті....
kasa0303
19.05.2022 14:06
Піднеси дл куба число записавши його у вигляді суми або різниці а) 18^3; б) 29^3...
ulanachukalkina
19.05.2022 14:06
Самые вкуснейшие яблоки или самые вкусные?...
Анастасия02052005
19.05.2022 14:06
???!?!?!Надо построить климатограмму по данным....
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
// Внимание! Если программа не работает, обновите версию!
begin
var a:=ArrRandom(15,-50,50); a.Println;
var b:=a.Select(t->2*t).ToArray; b.Println
end.
Пример
28 -22 -43 -36 -20 -21 36 -26 48 25 -31 -29 8 -35 17
56 -44 -86 -72 -40 -42 72 -52 96 50 -62 -58 16 -70 34
var
a,b: array [1..Sz] of integer;
N: integer; // Количество элементов в массиве
i: integer;
begin
N := 20;
for i:=1 to N do begin
a[i] := Random(100);
b[i]:=a[i]*2;
writeln('Элементы массива: ');
for i:=1 to N do
writeln(a[i],' ',b[i]);
end.