В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Aydan666
Aydan666
29.09.2022 08:24 •  Информатика

ЛЮДИ ДОБРЫЕ УМОЛЯЮ Напишите программу в Паскале, которая выводит случайное число в промежутке от 15 до N. Значение N вводится с клавиатуры и N ( знак больше)15.

Ответ:
voegrogo5523
voegrogo5523
24.08.2020 13:23

Должно работать это:

var N,r:integer; //нужные нам переменные

begin //СТАРТУЕМ!

 writeln('Впишите N. . .');  //просим ввести N

 readln(N); //получаем N

 randomize; //без этого рандом выдаёт одно и то же

 r := random(N-15+1)+15; //формула раандома

 writeln(r); //выводим рандомное число

end. //выключаем программу

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?