В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
rgmabbasov
rgmabbasov
05.08.2021 09:21 •  Информатика

Составьте программу на Паскале
На вход программы поступает неизвестное количество натуральных чисел, ввод заканчивается нулём. Найти минимальное из введённых нечётных чисел

Ответ:
AlexandraFox13
AlexandraFox13
13.10.2020 21:21

var a, min:integer;

begin

writeln('Введите числа (цифра 0 - выход из программы)');

readln(a);

min:= a;

while(a <> 0) do begin

 if (((a mod 2) = 1) and (min > a)) then

   min:= a;

readln(a);

end;

writeln('Минимальное нечетное число: ', min);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?