В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
SLI2000a
SLI2000a
01.03.2023 19:31 •  Информатика

Дана последовательность 1, 6, 11, 16, … . Составьте программу для
определения числа слагаемых, сумма которых не превышает 423.

Ответ:
Юльчик12134567890
Юльчик12134567890
24.08.2020 01:40

[python]

x, count = 1, 1

while(True):

   x += 5

   if x < 423:

       count += 1

   else: break

print(count)

[pascal]

var x, count: integer;

begin

   x := 1;

   count := 1;

   while(True) do

   begin

       x := x + 5;

       if x < 423 then count := count + 1

       else break;

   end;

   writeln(count);

end.

Почему count начинается с 1. Т.к. в последовательности есть число 1 (начальное значение x), то оно тоже является слагаемым и поэтому счетчик слагаемых начинаем с 1

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?