В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Vasilisa260216
Vasilisa260216
25.04.2021 12:26 •  Информатика

ПАСКАЛЬ
Составить программу для решения задач:
а) заполнить двумерный массив 10х10 целыми случайными числами в интервале (-5;20),вывести данный массив в виде таблицы.
б) найти сумму и произведение всех элементов данного массива.

Ответ:
3класс49
3класс49
13.09.2020 12:47

var A: array [1..10,1..10] of integer;

var i,j,s1: integer;

var s2: real;

begin

s1:=0;

s2:=1;

randomize();

For i:= 1 to 10 do

begin

 For j:= 1 to 10 do

 begin

 A[i,j]:=random(24)-4; // Поскольку интервал дан строгий (круглые скобки)

,

// если требовалось включить числа -5 и 20, замените эту строчку на следующую:  A[i,j]:=random(26)-5;

 write(A[i,j]:4);

 s1:=s1+A[i,j];

 s2:=s2*A[i,j];

 end;

 writeln();

end;

writeln('Сумма всех элементов: ',s1);

writeln('Произведение всех элементов: ',s2);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?