В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Zakharova2007
Zakharova2007
23.03.2023 23:53 •  Информатика

Задача 1. Составить программу для вычисления произведения N чисел.

Задача 2. Дано целое число n. Вычислить значение факториала n!
Теория: Рассмотрим, чему равняется 3! (факториал): P=3*2*1=6
Еще один пример: 5!: Р=5*4*3*2*1=120

Ответ:
64681
64681
13.10.2020 12:07

1)var n,i,sum: integer;

a: array [1..1000] of integer;

begin

writeln('Введите кол-во чисел N: ');

read(n);

sum:=1;

for I:= 1 to n do  

sum:=sum*i;

write('Произведение всех чисел = ',sum);

end.

2)var

 n, i, s: integer;

begin

 read(n);

 s := 1;

 for i := 1 to n do

   s := s * i;

 writeln(s);

end.

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?