В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
mariyavlasova2
mariyavlasova2
21.03.2022 12:12 •  Информатика

Составить программу на паскале. ввести 10 целых случайных чисел (в интервале от -10 до 10). вывести исходный массив. найти и вывести: 1) минимальный элемент и его индекс; 2) сумму всех элементов массива; 3) количество отрицательных элементов. к каждому элементу массива прибавить 1, вывести получившийся массив. подсказка: 1)random(10)-10 2) положительные: > 0 неположительные: < =0 отрицательные: < 0 неотрицательные: > =0

Ответ:
6aKalL
6aKalL
30.06.2020 14:58
Program gt;
var a:array[1..10]of integer;
i,min,l,s,k:integer;
begin
randomize;
s:=0;
k:=0;
for i:=1 to 10 do
begin
a[i]:=random(20)-10;
write(a[i],' ');
s:=s+a[i];
if(a[i]<0)then k:=k+1;
end;
min:=a[1];l:=1;
for i:=2 to 10 do
if(a[i]<=min)then begin
min:=a[i];
l:=i;
end;
writeln;
writeln('сумма элементов массива=',s);
writeln('кол-во отрицательных элементов массива=',k);
writeln('минимальный элемент массива=',min,' его индекс=',l);
for i:=1 to 10 do
begin
a[i]:=a[i]+1;
write(a[i],' ');
end;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?