В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
snezhkabo00
snezhkabo00
02.07.2020 10:11 •  Информатика

Напишите программу в паскале. Даны три одномерных массива из целых чисел. Найти элементы, принадлежащие всем трем массивам.

Ответ:
irabirykova18
irabirykova18
13.10.2020 01:16

const N = 10;

begin

var a := ArrRandom(N, 0, 20);

var b := ArrRandom(N, 0, 20);

var c := ArrRandom(N, 0, 20);

write('Массив a: '); a.Println();

write('Массив b: '); b.Println();

write('Массив c: '); c.Println();

write('Элементы, принадлежащие всем трем массивам: ');

a.FindAll(x->b.Contains(x) and c.Contains(x)).Distinct(

).PrintLn();

end.

Объяснение:

Первые три строки после begin создают три массива a,b,c и заполняют их N целыми числами в диапазоне от 0 до 20.

Конструкция "a.FindAll(x->b.Contains(x) and c.Contains(x)).Distinct().PrintLn();" делает следующее:

В массиве a выполняется поиск всех элементов (метод FindAll), удовлетворяющих условию:

x->b.Contains(x) and c.Contains(x)

Которое проверяет каждый элемент массива a (который обозначен x), содержится ли он в массиве b и массиве c (Методы Contains).

Далее метод Distinct удаляет все одинаковые элементы из получившейся  последовательности, а метод PrintLn выводит результат на экран.


Напишите программу в паскале. Даны три одномерных массива из целых чисел. Найти элементы, принадлежа
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?