В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
cocume
cocume
05.08.2020 08:46 •  Информатика

Написать программу, которая из слова «информатика» получает и выводит на экран слово «марка».

Подсказка к решению: Слова марка состоит из трех кусочков которые мы можем получить из слова «информатика»: ма, р, ка. Надо получит эти три части с команды copy и затем сложить их.

ма – copy (a,6,2) (кусочек берем из слова а= «информатика», буква м стоит на 6 месте, в кусочке 2 буквы)

Program slova;

Var a, b: string;

Begin a:=’информатика’;

b:= copy (a,6,2) + copy (a,5,1) + copy (a,10,2);

WriteLn (b);

End.

Ответ:
dgfhdhdj95
dgfhdhdj95
13.10.2020 09:45

По идеи, строки в Паскале являются одномерными массивами, легче просто присвоить второй строке символы из первой строки:

b:= a[6]+a[2] ...

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?