В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Veteran1941
Veteran1941
09.10.2020 16:18 •  Информатика

Написать программу в Pascal ABC. Дана строка, слова в строке разделены пробелами, сколько слов в этой строке?

Ответ:
ГришаМститель
ГришаМститель
15.10.2020 21:41

Если считать, что количество пробелов между словами всегда равно 1, а также что нет пробелов до и после последовательности, то количество слов = количеству пробелов + 1.

Код:

program words;var    s: string;    k, i: integer;begin    WriteLn('Введите последовательность слов с пробелами:');    ReadLn(s);    k := 1;    for i := 1 to length(s) do        if s[i] = ' ' then k := k + 1;    WriteLn('Кол-во слов: ', k);end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?