В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
diamond1277p08lfa
diamond1277p08lfa
14.03.2021 19:43 •  Информатика

Написать программу, в которой осуществляется ввод целых чисел(ввод до тех пор, пока не будет введен ноль) и подсчет суммы введенных положительных чисел. Сделать блок схемой( )

Ответ:
jarretquinswid
jarretquinswid
13.10.2020 07:57

Добрый вечер. (ночи :) )

Сделать схемкой не могу но вот написал прогу. Надеюсь Сейчас попробую сделать схему, но не обещаю удачи.

(P.S. Протестил)

var a,sum:integer;

begin

 sum:=0;

 repeat

    readln(a);

    if a>0 then  

    begin

       sum:=sum+a;

    end;

 until a = 0;

 writeln('Сумма ',sum:5);

end.

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?