В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
elizavetachery
elizavetachery
10.08.2022 15:46 •  Информатика

НЕ ПОЛУЧАЕТСЯ РЕШИТЬ! Напишите программу, которая находит кота.
Пользователь вводит строки до тех пор, пока он не введёт «СТОП». Программа выводит номер строки, на которой впервые был упомянут кот (в том же смысле, что и в предыдущей задаче), или -1 (минус один), если кот не был упомянут.

Формат ввода
Несколько строк.
Сигнал остановки — строка «СТОП».

Формат вывода
Одно число — номер первой строчки, в которой появился кот, или -1, если кота нет.

Пример
Ввод
Как устроен типичный фрукт:
кожура;
мякоть;
косточки.
СТОП
Вывод;
3

Ответ:
1234567891219
1234567891219
25.11.2020 17:34

a = 0

b = 0

c = True

while True:

   v = input()

   a += 1

   if 'кот' in v.lower() and c:

       b = a

       c = False

   if 'стоп' in v.lower():

       break

if not b:

   b = -1

print(b)

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?