В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
arelbeis
arelbeis
15.04.2023 18:18 •  Информатика

Какое значение имеет массив в математике и программировании?​

Ответ:
PahaBroZ
PahaBroZ
13.10.2020 07:11

ответ:Нужны для оперирования множеством однотипных данных с всего лишь одного идентификатора. Могут найти применение в решении практически любых задач. Математика - лишь одна из таких.

0,0(0 оценок)
Ответ:
arina1238
arina1238
13.10.2020 07:11

При запуске программы массив для неё не имеет никакого значения. Он создан только для того чтобы программистам было написать программу.

Пример(он будет на языке С++ но суть думаю будет понятна)

Создадим 5 переменных

int a1 = 1;

int a2 = 2;

int a3 = 3;

int a4 = 4;

int a5 = 5;

И вот для того чтобы вывести нам нужно будет написать

cout << a1 << a2 << a3 << a4 << a5;

Это не удобно по этому программисты придумали массивы.

Создадим массив для 5 элементов

int a[4]; // Так как отчёт начинает с нуля. 0,1,2,3,4

и заполним, а так же выведем его при цикла

for(int i = 1; i<=4; i++){

a[i] = i;

cout << a[i];

}

Код стал намного меньше и намного лучше читабельный.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?