В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
taykinamatilda
taykinamatilda
22.03.2023 04:52 •  Информатика

Составить программу получающую на входе целое число a. Если a меньше 0, тогда a:=a+3, иначе a:=a-1. Какой результат выдаст программа при a = 0, a = -5, a=5?
Составить программу в паскаль, если можно то скрином из паскаля!

Ответ:
alinasad337
alinasad337
12.10.2020 09:16

var

 a: integer;

begin

 Read(a);

 if a < 0 then a := a + 3 else a := a - 1;

 Writeln('Конечный результат', a);

end.

Тестовое решениеЖ

Введите А := 0

Конечный результат-1

Введите А  -5

Конечный результат-2

Введите А  -5

Конечный результат 4

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?