В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Tony271
Tony271
16.12.2022 16:03 •  Информатика

Напишите программу, которая в последовательности целых чисел определяет из колличество и сумму четных чисел. программа получает на ход целые числа, колличество введенных чисел неизвестно послкдовательность чисел заканчивается числом 0 признак окончания ввода не взолит в последовательность. колличество чисел не привышает 1000. введеные числа по модулю не привышают 30000. программа должна вывести два числа длину последовательности и сумму четных чисел.
введные данные выходные
4 3
60 64
15
0

Ответ:
daniilprok2004
daniilprok2004
11.10.2020 21:54

program kol_sum_chet;

var

x,k,s:integer;

begin

k:=0;

s:=0;

repeat

read(x);

if x mod 2=0

then

begin

s:=s+x;

inc(k);

end;

until x=0;

write(k,' ',s)

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?