Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
dbdbbdns
05.12.2020 19:33 •
Информатика
Напишите программу в паскале, где дано натуральное число n и вычислить произведение первых n-сомножителей: а) 1*3/2*5/ б) 1*1/3*1/
Ответ:
Keterina0905keka
05.10.2020 14:39
Var
N,i,j:integer;
P:real;
Begin
i:=1;
j:=1;
P:=1;
WriteLn('Введите число N');
ReadLn(N);
Write('а:1');
While i<>n do
begin
j:=j+2;
i:=i+1;
P:=P*(j/i);
Write('*',j,'/',i);
end;
Write('=',P);
WriteLn();
Write('б:1');
i:=1;
j:=1;
P:=1;
While i<>n do
begin
j:=j+2;
i:=i+1;
P:=P/i;
Write('*1/',j);
end;
Write('=',P);
End.
0,0
(0 оценок)
Популярные вопросы: Информатика
lusikv83
04.06.2023 16:20
Найдите сумму 10111102 и 11001112 а)110001012 в)11110002 с)111000112 d)10011012 напишите с решением...
Anna3367171
04.06.2023 16:20
Как называется элементарная операция, из которых состоит выполнение каждой команды процессора?...
dima0124124
04.06.2023 16:20
Как называется элементарная операция, из которых состоит выполнение каждой команды процессора?...
mashasandalkina
27.05.2022 17:29
У исполнителя Дельта две команды, которым присвоены номера: 1. прибавить 6 2. умножить на d (d – неизвестное натуральное число; d 1) Выполняя первую из них, Дельта увеличивает...
Qdiiit
18.05.2023 13:15
101010+1110=?в двоичную1010+1010=?в двоичную10101+111=?в двоичную.решите ...
Mom34
01.09.2021 05:27
С++.Гужно решать на язукнс...
Иваныч71
09.02.2022 10:10
Мы сделали кнопки в pascalabc.net. как сделать так, чтобы когда на них нажимаешь, то выводился на экран текст. заранее . вот код программы: uses graphabc, abcobjects,abcbuttons;...
ВанькаНер
09.02.2022 10:10
Найдите основание системы счисления, в которой выполнено следующее сложение: 144 + 24 = 201. с решением...
lowander3000
23.10.2021 02:20
Нужно сделать двумерный массив 3х4 и вычислить сколько элементов в данном массиве меньше числа n.(его с клавы ввести нужно). И random(100)...
dasha098685674
20.07.2020 12:52
На складе было 1300 коробок стирального порошка . за первую неделю израсходовали всего порошка , а за вторую - 54 % остатка . сколько порошка израсходовали за вторую неделю...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
N,i,j:integer;
P:real;
Begin
i:=1;
j:=1;
P:=1;
WriteLn('Введите число N');
ReadLn(N);
Write('а:1');
While i<>n do
begin
j:=j+2;
i:=i+1;
P:=P*(j/i);
Write('*',j,'/',i);
end;
Write('=',P);
WriteLn();
Write('б:1');
i:=1;
j:=1;
P:=1;
While i<>n do
begin
j:=j+2;
i:=i+1;
P:=P/i;
Write('*1/',j);
end;
Write('=',P);
End.