В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык

С клавиатуры вводятся 10 чисел
Написать программу, которая определяет наименьшее и наибольшее. Pascal ABC

Ответ:
sergeicyupka
sergeicyupka
11.10.2020 16:03

const

n=10;

type

mas = array [1..n] of real;

procedure search(massive : mas);

var j : integer;

max, min : real;

begin

 max := 1;

 min := 1;

 for j:=1 to n do

   begin

     if massive[j] > max then

        max := massive[j];

     if massive[j] < min then

       min := massive[j];

   end;    

  writeln;

  writeln('наибольший элемент: ', max);  

  writeln('наименьший элемент: ', min);

end;

var

i : integer;

a : mas;

begin

 writeln('введите массив: ');

 for i:=1 to n do

     read(a[i]);

 writeln('массив: ' );

 for i:=1 to n do

   write(a[i]:4);

 search(a);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?