В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Bdbdbbfbrhr
Bdbdbbfbrhr
27.01.2022 21:45 •  Информатика

Написать программу в паскале, которая формирует матрицу nXn в следующем виде: У меня есть программа, которая формирует матрицу в виде:
1 1 1 1 1 1 1 1 1 1
2 2 2 2 2 2 2 2 2 1
3 3 3 3 3 3 3 3 2 1
4 4 4 4 4 4 4 3 2 1
5 5 5 5 5 5 4 3 2 1
6 6 6 6 6 5 4 3 2 1
7 7 7 7 6 5 4 3 2 1
8 8 8 7 6 5 4 3 2 1
9 9 8 7 6 5 4 3 2 1
10 9 8 7 6 5 4 3 2 1
И программа для нее:
var
n,i,j: integer;
a: array[1..20,1..20] of integer;
begin
write('Введите размерность матрицы');
readln(n);
for i:=1 to n do
begin
for j:=1 to n do
begin
if i+j a[i,j]:=n-j+1;
write(a[i,j]:4);
end;
writeln;
end;
end.


Написать программу в паскале, которая формирует матрицу nXn в следующем виде: У меня есть программа,

Ответ:
nika0483
nika0483
04.11.2020 14:00

1

1

1

1

1

2

3

4

5

6

End end endend

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?