В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
King20051
King20051
19.03.2022 10:46 •  Информатика

Составьте программу на Паскале для заполнения массива из 100 чисел случайными значениями из диапазона от -30 до 30. Подсчитайте в этом массиве количество положительных и количество отрицательных чисел.

Ответ:
dbonapik
dbonapik
11.10.2020 15:12

===== PascalABC.NET =====

begin

 var a := ArrRandom(100, -30, 30);

 a.Println;

 Writeln;

 var пол := a.Count(p -> p > 0);

 var отр := a.Count(p -> p < 0);

 Write('положительных ', пол, ', отрицательных ', отр)

end.


Составьте программу на Паскале для заполнения массива из 100 чисел случайными значениями из диапазон
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?