В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Aldik81
Aldik81
20.07.2020 05:53 •  Информатика

Найти средний рост 32 учеников . нужно написать программу!

Ответ:
mariiiiii222
mariiiiii222
09.07.2020 22:00
Var
  i, n, s: integer;

begin
  s := 0;
  Writeln('Введите через пробел 32 значения роста в см');
  for i := 1 to 32 do
  begin
    Read(n);
    s := s + n
  end;
  Write('Средний рост равен ', s / 32:0:1, ' см')
end.

Тестовое решение:

Введите через пробел 32 значения роста в см
157 153 169 169 157 162 160 159 152 159 152 166 159 167 164 153 170 155 170 170 161 155 151 153 161 159 170 166 160 159 161 152
Средний рост равен 160.3 см
0,0(0 оценок)
Ответ:
nastafill
nastafill
09.07.2020 22:00
Var
mas:array[1..32] of real;
i,k:integer;
sum:real;
begin
for i:= 1 to 32  do 
begin write('Введите рост ',i,' ученика'); readln(mas[i]) end;
writeln;
sum:=0;
k:=0;
for i:= 1 to 32 do 
begin sum:=sum+mas[i]; k:=k+1 end;
write(sum/k)
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?