В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
asdx1984
asdx1984
06.05.2021 09:32 •  Информатика

Заданной двузначное число. Составьте программу с которой определите произведения квадратов цифр этого числа( на языке pascal)

Ответ:
dariyaomelchen
dariyaomelchen
11.10.2020 14:46

Язык: Pascal

program z1;

var a, x, y, b: integer;

begin

read(a);

x:= a div 10;

y:= a mod 10;

x:= sqr(x);

y:= sqr(y);

b:= x*y;

writeln('Квадрат первой цифры числа = ', x);

writeln('Квадрат второй цифры числа = ', y);

writeln('Произведение квадратов чисел = ', b);

end.

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?